Sony SA-CT370 just won't work

I absolutely cannot get a Sony SA-CT370 soundbar to respond to IR from the iTach. I know the iTach works perfectly because it controls everything else without a hitch. The soundbar responds perfectly to the factory remote, but that's it.

I've tried the codes from GlobalCache's IR code database, I've tried the codes after manually learning them straight from the factory remote (the learned codes are identical to those in the GC database), but nothing works.

I've tried it with the "blaster" emitter, which controls everything else in the room without a hitch. It's a very small room with low angled white ceilings to bounce the signal around, so the blaster approach should cover everything. Not this soundbar, though.

I've tried it with a dedicated emitter, both at distance and taped directly on top of the soundbar's remote sensor.

My need is to use the codes in a Mac-based home automation software package called Indigo. There's a plugin for GC devices that works great. You input the hex command to send into the action you're configuring, tell it how many times to repeat the code, and that's that. In the case of Sony codes, however, I paste in the following hex values as the IR code to send for the power toggle:

0000 0067 0000 0010 0060 0018 0030 0018 0018 0018 0030 0018 0018 0018 0030 0018 0018 0018 0018 0018 0018 0018 0018 0018 0018 0018 0018 0018 0030 0018 0030 0019 0018 0018 0018 035E

...and it gets saved to the config like this:

sony:8 0030/15

Could this auto-formatting that the app is doing be the source of the trouble? I notice that Sony is the only brand for which hex codes are being auto-reformatted and all other brands of gear I try work fine.


Please sign in to leave a comment.