iTach WiFi to IR, can't see it as an available adhoc network

Hey all,

Brand new here. This is the first IR device I ever purchased but long time programmer.

I received the new device in the mail yesterday and I read the quick instructions, very basic. Plug it in, I'll see it broadcasting (SSID) as "GlobalCache[macaddr]" where macaddr is the number on the sticker under the unit.

I plug it in. The power and all 3 emitter ports blink a few times and then just the green power led is on. I look on available wifi networks and it's not there. My laptop's internal mobo is fully compatible with b/g/n networks. I see a ton of networks (almost everyone uses 5 characters). None of them are this device.

I read the manual that to reset the device, use a paper clip and insert it into the hole to the right of the power plug 1/8". I did that but there appears to be no button there. I think that's the IR "learner" sensor. I put the clip in until it hit something and pressed very gently to see if it was a button and it didn't budge. I'm assuming this unit does not have a reset like the FAQ/docs says it should.

I tried looking for this WiFi iTach on 4 devices. A laptop (dell studio 17 touch), HTPC (3-channel PCI-E NIC card compatible with all networks) and 2 phones (Samsung Galaxy SIII and iPhone5). The device is simply not broadcasting.

I saw a USB to power adaptor in the box. I connected the device directly to my laptop incase that helped. It blinked with power, same as the AC outlet, but still no device on the network.

I plugged in some of the emitters (getting desperate now), nothing.

I disabled WiFi-N support on my NIC card and enabled enhanced G mode. Nothing..

I left it unplugged, replugged several times, nothing on the network.

Lastly I tried creating a new network connection directly to my devices SSID (per instructions, as mentioned above, should be "GlobalCache000etc...."). It couldn't find that network.

Is there anything I can do connecting it directly via USB to a computer with the USB->Power cord that would let me access the device and perhaps try to update firmware or anything? Or is this just a defective device?

Thanks for tips!


Please sign in to leave a comment.